How we use AI in our process

Learn more
Critical

Vulnerability in WordPress REST API

WordPress

What happened

A security issue in WordPress could allow an attacker to execute remote code due to a flaw in the REST API. This vulnerability is combined with a SQL injection vulnerability that affects specific versions of WordPress.

Are you affected?

WordPress versions 6.9.0 through 6.9.4 and 7.0.0 through 7.0.1 are affected.

What to do now

  1. Upgrade to WordPress version 6.9.5 or 7.0.2 as soon as possible.
  2. Regularly review your WordPress installation for unauthorized access or changes.

Sources

Data sources: cve.now, CISA KEV, GitHub Advisory Database, OSV.

This product uses data from the NVD API but is not endorsed or certified by the NVD.

Not sure if your app is affected?

Get a free Finish Line Scan and a senior engineer will tell you what to fix.

Get a free scan